Get in touch
Back
Maintenance

Database Upgrade

Completed 3 Aug at 04:30pm CEST.

Application Signatures Signatures on custom domains
Completed

Maintenance completed

Posted 3 Aug at 04:30pm CEST.
Started

Application and signature image will be unavailable during the maintenance

Posted 3 Aug at 02:00pm CEST.