Back to overview
Downtime
Major outage
Nov 7, 2022 at 8:02am UTC
Affected services
Api
Signatures
Signatures on custom domains
Resolved
Nov 7, 2022 at 2:22pm UTC
We have identified the root cause of the issue and fixed it.
Sorry for the inconvenience
Affected services
Created
Nov 7, 2022 at 8:02am UTC
We have a downtime on all of our services and are currently investigating the issue
Affected services