Back to overview
Downtime
Application is not available
Nov 20, 2023 at 1:00pm UTC
Affected services
Api
Resolved
Nov 20, 2023 at 2:50pm UTC
Everything is back to normal
Affected services
Created
Nov 20, 2023 at 1:00pm UTC
The application is not available due to an unscheduled maintenance. Signatures are working perfectly, thanks for your patience
Affected services