Back to overview
Degraded

Signature images may be broken in Gmail

Oct 15, 2025 at 2:33pm UTC
Affected services
Signatures
Signatures on custom domains

Resolved
Oct 16, 2025 at 8:30am UTC

The issue has been resolved
Don't hesitate to refresh your Gmail if you still see missing images

Created
Oct 15, 2025 at 2:33pm UTC

Due to a DNS provider migration, signature may be broken in Gmail.
The issue is fixed, but Gmail cached the wrong data, everything should be back in order in a few hours